Treo 650 Updater 1.15 for Cingular (PalmOne)

for Cingular Wireless, including former AT&T Wireless customers)
Posted July 25, 2005

What is the Treo 650 Updater 1.15?
Do I need the Treo 650 Updater 1.15?
System Requirements
Download & Install
Windows
Macintosh
If you are not a Cingular Wireless customer, do not download this version of the software. It contains carrier-specific requirements that are incompatible with non-Cingular phones. Not a Cingular customer? Click here for the appropriate Treo 650 Updater.

Advertisements